summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <kent.boortz@sun.com>2008-11-06 19:38:19 +0100
committerBuild Team <bteam@astra04>2008-11-06 19:38:19 +0100
commit2f08a0798d935ccd93e4bc2ee34dd60e0c9c3c0f (patch)
tree597b1c9155fa14c05cfc6653eba9966dc7eb73bd /configure.in
parente9be23fae6129b96cf20fa5a0938a7bad77a5df2 (diff)
downloadmariadb-git-2f08a0798d935ccd93e4bc2ee34dd60e0c9c3c0f.tar.gz
Back merges from 6.0.8
- Removed some copy/paste between debug and normal build in RPM spec - Removed "mysql_upgrade_shell" from RPM build - Removed use of "grep -q" in "configure.in", not portable - Improved test to disable ABI check not to accidently run for icc Other changes - Added make file test targets 'test-bt-fast' and 'test-bt-debug-fast' - Reenabled "jp" test suite run
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 63ab547f70d..c57c1efee9f 100644
--- a/configure.in
+++ b/configure.in
@@ -377,7 +377,7 @@ fi
MYSQL_PROG_AR
# libmysqlclient versioning when linked with GNU ld.
-if $LD --version 2>/dev/null|grep -q GNU; then
+if $LD --version 2>/dev/null| grep GNU >/dev/null 2>&1; then
LD_VERSION_SCRIPT="-Wl,--version-script=\$(top_builddir)/libmysql/libmysql.ver"
AC_CONFIG_FILES(libmysql/libmysql.ver)
fi
@@ -449,11 +449,11 @@ AC_SUBST(PERL5)
# Enable the abi_check rule only if gcc is available
-if expr "$CC" : ".*gcc.*"
+if test "$GCC" != "yes" || expr "$CC" : ".*icc.*"
then
- ABI_CHECK="abi_check"
-else
ABI_CHECK=""
+else
+ ABI_CHECK="abi_check"
fi
AC_SUBST(ABI_CHECK)