summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2006-07-26 16:00:11 +0200
committerunknown <msvensson@neptunus.(none)>2006-07-26 16:00:11 +0200
commit17e310abc12e559d2eb4b0254aa5f88d7720cf4f (patch)
treef03034cb0056b32173a9f8c9739d1410109cbbd7 /configure.in
parent6528be27b56e0979f7f8682f5193bacff1cd1e82 (diff)
downloadmariadb-git-17e310abc12e559d2eb4b0254aa5f88d7720cf4f.tar.gz
Bug#16576 Patch to compile on GNU/Hurd (ps check in configure)
- Thanks to Christian Hammers for the patch configure.in: The configure check on how to run ps to get mysqld's $PID does not work on the Hurd, as the PPID is prepended with a - for login shells, thus making grep look for -bash, which it complains as an invalid argument. Filtering out '-' from the ps output makes this work fine.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d4ee825a47f..f3c6ed70a2b 100644
--- a/configure.in
+++ b/configure.in
@@ -454,7 +454,7 @@ AC_PATH_PROG(PS, ps, ps)
AC_MSG_CHECKING("how to check if pid exists")
PS=$ac_cv_path_PS
# Linux style
-if $PS p $$ 2> /dev/null | grep $0 > /dev/null
+if $PS p $$ 2> /dev/null | grep `echo $0 | sed s/\-//` > /dev/null
then
FIND_PROC="$PS p \$\$PID | grep -v grep | grep \$\$MYSQLD > /dev/null"
# Solaris