summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathan Perkin <jperkin@sun.com>2008-08-20 12:32:34 +0100
committerJonathan Perkin <jperkin@sun.com>2008-08-20 12:32:34 +0100
commitded12789afe850f25ea08ab67c22d6054df549af (patch)
tree681d59e4a9a7a173b12ac7dc8955420f6116acbe /Makefile.am
parent857718e28b0eeb6ffc567cf1940d8f67523611a7 (diff)
downloadmariadb-git-ded12789afe850f25ea08ab67c22d6054df549af.tar.gz
bug#33300: use myisamchk to verify that mysql_install_db has
created at least some files and that they are correct.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fc5138e2778..1061f64a0dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,7 +49,7 @@ bin-dist: all
$(top_builddir)/scripts/make_binary_distribution @MAKE_BINARY_DISTRIBUTION_OPTIONS@
# Remove BK's "SCCS" subdirectories from source distribution
-# Create initial database files for Windows installations.
+# Create initial database files for Windows installations and check them.
dist-hook:
rm -rf `find $(distdir) -type d -name SCCS -print`
mkdir -p $(distdir)/win
@@ -57,6 +57,7 @@ dist-hook:
--builddir=$(top_builddir) \
--datadir=$(distdir)/win/data \
--srcdir=$(top_srcdir)
+ myisam/myisamchk --silent --fast $(distdir)/win/data/mysql/*.MYI
tags:
support-files/build-tags