summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <omer@linux.site>2007-03-15 14:28:32 -0700
committerunknown <omer@linux.site>2007-03-15 14:28:32 -0700
commitd60833fe729f52509bb270dcbe34d1d9db3daade (patch)
tree529b11e9af81dbd0b681b04b0ea445a7589899f3 /Makefile.am
parent0d31e0f3cfab1f90b24fc0fa716ce590dd60cd91 (diff)
downloadmariadb-git-d60833fe729f52509bb270dcbe34d1d9db3daade.tar.gz
Added test options to Makefile.am including
- test suites developed by QA - additional 'fast' test options Makefile.am: Added test options to cover - test suites developed by QA - additional 'fast' test options
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 32 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 04d50ccfbaf..3a1bfc0e32a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,7 +112,9 @@ tags:
.PHONY: init-db bin-dist \
test test-force test-full test-force-full test-force-mem \
test-pl test-force-pl test-full-pl test-force-full-pl test-force-pl-mem \
- test-ps test-ns
+ test-ps test-ns test-ext-funcs test-ext \
+ test-fast test-fast-cursor test-fast-view test-fast-prepare \
+ test-full-qa
# Target 'test' will run the regression test suite using the built server.
#
@@ -124,11 +126,11 @@ tags:
test-ps:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force) --ps-protocol
+ @PERL@ ./mysql-test-run.pl $(force) $(mem) --ps-protocol
test-ns:
cd mysql-test ; \
- @PERL@ ./mysql-test-run.pl $(force)
+ @PERL@ ./mysql-test-run.pl $(force) $(mem)
test: test-ns test-ps
@@ -143,7 +145,7 @@ test-force-full:
#used by autopush.pl to run memory based tests
test-force-mem:
- $(MAKE) 'force=--force --mem' test
+ $(MAKE) force=--force mem=--mem test
# Keep these for a while
test-pl: test
@@ -152,5 +154,31 @@ test-force-pl: test-force
test-force-pl-mem: test-force-mem
test-force-full-pl: test-force-full
+test-ext-funcs:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=funcs_1 ; \
+ @PERL@ ./mysql-test-run.pl --force --suite=funcs_2
+
+test-ext: test-ext-funcs
+
+test-fast:
+ cd mysql-test ; \
+ @PERL@ ./mysql-test-run.pl $(subset) --force --skip-ndb --skip-innodb --skip-im --skip-rpl ; \
+ @PERL@ ./mysql-test-run.pl $(subset) --force --suite=funcs_1 --do-test=myisam
+
+test-fast-view:
+ $(MAKE) subset=--view-protocol test-fast
+
+test-fast-cursor:
+ $(MAKE) subset=--cursor-protocol test-fast
+
+test-fast-prepare:
+ $(MAKE) subset=--ps-protocol test-fast
+
+test-full-qa:
+ $(MAKE) force=--force test-pl \
+ test-ext test-fast-view \
+ test-fast-cursor
+
# Don't update the files from bitkeeper
%::SCCS/s.%