summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <serg@serg.mylan>2006-04-12 14:08:24 +0200
committerunknown <serg@serg.mylan>2006-04-12 14:08:24 +0200
commitc566f9a25f53ea88ef75d2f4d6e8c6f61745b3e7 (patch)
tree46aa796924bcff90935d9149ffb0d65ac7c6ae61 /Makefile.am
parentef1ec197449dbfc00f64834af4564021368ac765 (diff)
downloadmariadb-git-c566f9a25f53ea88ef75d2f4d6e8c6f61745b3e7.tar.gz
fixes for 'make dist' and 'make distcheck'
BUILD/compile-dist: fixes for 'make dist' and 'make distcheck' include yassl in "dist" Makefile.am: fixes for 'make dist' and 'make distcheck' remove double-listing of everything in SUBDIRS and DIST_SUBDIRS remove @yassl_dir@, it belongs to extra/Makefile.am specify --basedir for mysql_install_db, in case builddir (where mysql_install_db is) differs from srcdir (where mysql_fix_privilege_tables.sql is) config/ac-macros/yassl.m4: fixes for 'make dist' and 'make distcheck' create Makefile's only if yassl is used yassl_dir must not include / config/ac-macros/zlib.m4: fixes for 'make dist' and 'make distcheck' create Makefile only if zlib is used configure.in: fixes for 'make dist' and 'make distcheck' create Makefile only if a feature is enabled storage engine dirs must not include / automatically disable readline/libedit/sql-bench if source dir is missing extra/Makefile.am: fixes for 'make dist' and 'make distcheck' remove SUBDIR/DIST_SUBDIR hack libmysql_r/Makefile.am: fixes for 'make dist' and 'make distcheck' when symlinking all files from libmysql/ take into account that srcdir != builddir libmysqld/Makefile.am: fixes for 'make dist' and 'make distcheck' remove fragile promiscuous search for object files if .o file is not where we look for it - extract it from the library mysql-test/ndb/Makefile.am: fixes for 'make dist' and 'make distcheck' ndbcluster script is not a "source" don't forget to cleanup plugin/Makefile.am: fixes for 'make dist' and 'make distcheck' include plugin/fulltext/configure.in template in the distribution storage/Makefile.am: fixes for 'make dist' and 'make distcheck' remove SUBDIRS/DIST_SUBDIRS hack storage/ndb/Makefile.am: fixes for 'make dist' and 'make distcheck' force common.mk.am out of DIST_COMMON (which is otherwise an auto-generated list of Makefile's sources) because it's listed indirectly in EXTRA_DIST, and with bk -r get, a file cannot be copied twice.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f17cbe797d..c9cffd79529 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,25 +21,17 @@ AUTOMAKE_OPTIONS = foreign
# These are built from source in the Docs directory
EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
README COPYING EXCEPTIONS-CLIENT cmakelists.txt
-SUBDIRS = . include @docs_dirs@ @zlib_dir@ @yassl_dir@ \
+SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
@readline_topdir@ sql-common \
@thread_dirs@ pstack \
- @sql_union_dirs@ @mysql_se_dirs@ \
+ @sql_union_dirs@ storage \
@sql_server@ scripts @man_dirs@ tests \
@mysql_se_plugins@ \
netware @libmysqld_dirs@ \
@bench_dirs@ support-files @tools_dirs@ \
plugin win
-DIST_SUBDIRS = . include @docs_dirs@ zlib \
- @readline_topdir@ sql-common \
- @thread_dirs@ pstack \
- strings mysys dbug extra regex storage \
- vio sql libmysql_r libmysql client scripts \
- @man_dirs@ tests SSL\
- BUILD netware os2 @libmysqld_dirs@\
- @bench_dirs@ support-files server-tools tools \
- plugin win
+DIST_SUBDIRS = $(SUBDIRS) SSL BUILD os2
# Run these targets before any others, also make part of clean target,
# to make sure we create new links after a clean.
@@ -100,9 +92,11 @@ dist-hook:
rm -rf `find $(distdir) -type d -name SCCS -print`
if echo "$(distdir)" | grep -q '^/' ; then \
scripts/mysql_install_db --no-defaults --windows \
+ --basedir=$(top_srcdir) \
--datadir="$(distdir)/win/data"; \
else \
scripts/mysql_install_db --no-defaults --windows \
+ --basedir=$(top_srcdir) \
--datadir="$$(pwd)/$(distdir)/win/data"; \
fi