summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNarayanan V <v.narayanan@sun.com>2008-08-06 23:43:37 +0530
committerNarayanan V <v.narayanan@sun.com>2008-08-06 23:43:37 +0530
commit3236c07b7f75473bc46da8a526ca9300c6d0b894 (patch)
tree861b85f8c8e3b1934475552ca7db4a49a75304f5 /Makefile.am
parente3e2331cddf9ca1114fdbcc82c843264ddb8d434 (diff)
downloadmariadb-git-3236c07b7f75473bc46da8a526ca9300c6d0b894.tar.gz
WL#4380
1) Remove solaris sparc specific output produced by the pre-processor in the .out files 2) Ensure compatibility of preprocessor options for solaris/sparc platform. Makefile.am: 1) Added a sed regular expression to remove output produced by the preprocessor in the solaris sparc platform 2) Removed the -dI option from the preprocessor to enable solaris/sparc compatibility include/mysql.h.pp: Since the -dI option has been removed from the preprocessor the .pp files will correspondingly change.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 77318baf07e..409504bddff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -259,12 +259,10 @@ TEST_PREPROCESSOR_HEADER = $(top_srcdir)/include/mysql/plugin.h \
# to prevent seeing these messages.
# 2) sed the output to
# 2.1) remove blank lines and lines that begin with "# "
-# (The header information is retained to enable easy
-# analysis of abi diffs at a later stage).
-# 2.2) When gcc -E is run in the Mac OS it introduces a line of output
-# that results in showing up as a difference between the .pp and
-# .out files. Remove this OS specific preprocessor text inserted by
-# the preprocessor in the MAC OS.
+# 2.2) When gcc -E is run on the Mac OS and solaris sparc platforms it
+# introduces a line of output that shows up as a difference between
+# the .pp and .out files. Remove these OS specific preprocessor text
+# inserted by the preprocessor.
# 3) diff the generated file and the canons (.pp files already in
# the repository).
# 4) delete the .out file that is generated.
@@ -294,7 +292,7 @@ abi_check_all: $(TEST_PREPROCESSOR_HEADER)
do_abi_check:
set -ex; \
for file in $(abi_headers); do \
- @CC@ -E -nostdinc -dI \
+ @CC@ -E -nostdinc \
-I$(top_srcdir)/include \
-I$(top_srcdir)/include/mysql \
-I$(top_srcdir)/sql \
@@ -304,7 +302,8 @@ do_abi_check:
$$file 2>/dev/null | \
@SED@ -e '/^# /d' \
-e '/^[ ]*$$/d' \
- -e '/^#pragma GCC set_debug_pwd/d' > \
+ -e '/^#pragma GCC set_debug_pwd/d' \
+ -e '/^#ident/d' > \
$(top_builddir)/abi_check.out; \
@DIFF@ -w $$file.pp $(top_builddir)/abi_check.out; \
@RM@ $(top_builddir)/abi_check.out; \