summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-01-24 21:03:21 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-01-24 21:03:21 +0100
commit4fe79c7d58549b7490f51c7273440234a0f6b5be (patch)
tree4c6915b549ccc00cb4099476b7a5de5c68f95553 /CMakeLists.txt
parentb4d6a13510dbd5bc2eebdd44e5eaec02d8f3725b (diff)
downloadmariadb-git-4fe79c7d58549b7490f51c7273440234a0f6b5be.tar.gz
Following autotools tradition, add preprocessor definitions specified in environment variable CPPFLAGS
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 668675d4444..f63e31d9cc0 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,6 +61,11 @@ ENDIF()
PROJECT(MySQL)
+# Following autotools tradition, add preprocessor definitions
+# specified in environment variable CPPFLAGS
+IF(DEFINED ENV{CPPFLAGS})
+ ADD_DEFINITIONS($ENV{CPPFLAGS})
+ENDIF()
IF(CYGWIN)
SET(WIN32 0)