summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2015-02-17 15:20:19 -0500
committerRyan Lortie <desrt@desrt.ca>2015-02-17 15:21:47 -0500
commit7152aae4ee2af0dc3520168891a0e72e84fba727 (patch)
tree05400462b0e519c5ad383e4ad7df126120abb7ed /Makefile.am
downloadm4-common-7152aae4ee2af0dc3520168891a0e72e84fba727.tar.gz
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..69c8869
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+aclocaldir = $(prefix)/share/aclocal
+
+# sorted, please
+dist_aclocal_DATA = \
+ autoconf-archive/m4/ax_append_compile_flags.m4 \
+ autoconf-archive/m4/ax_append_flag.m4 \
+ autoconf-archive/m4/ax_check_compile_flag.m4 \
+ autoconf-archive/m4/ax_is_release.m4 \
+ autoconf-archive/m4/ax_compiler_flags.m4 \
+ autoconf-archive/m4/ax_compiler_flags_cflags.m4 \
+ autoconf-archive/m4/ax_compiler_flags_cxxflags.m4 \
+ autoconf-archive/m4/ax_compiler_flags_ldflags.m4 \
+ autoconf-archive/m4/ax_compiler_flags_gir.m4 \
+ autoconf-archive/m4/ax_require_defined.m4 \
+ $(NULL)
+
+all-local: $(dist_aclocal_DATA)
+ cat $^ | grep -v '^#' | sed -e 's/\<dnl\>.*//' | grep -o '\<AX_[A-Z0-9_]*\>' | sort | uniq > used
+ cat $^ | grep ^AC_DEFUN | grep -o '\<AX_[A-Z0-9_]*\>' | sort | uniq > defined
+ diff -u used defined
+ rm -f used defined