summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Gerecke <jason.gerecke@wacom.com>2022-02-18 13:51:20 -0800
committerPeter Hutterer <peter.hutterer@who-t.net>2022-02-22 10:41:51 +1000
commite217fe67690ff8d00af6ccc2bbe65720af21a979 (patch)
tree3966b1f3577f1ba384242d94f95e832d3d096c48 /configure.ac
parentb708574c48b5e57dc5fc7efa4ec7d102c062071f (diff)
downloadxf86-input-wacom-e217fe67690ff8d00af6ccc2bbe65720af21a979.tar.gz
Move -Wall and -Wextra from Github-only to default CFLAGS
These two options were previously only being used by the Github runner. Lets move them to configure.ac / meson.build so that we encounter these warnings on our build system **before** pushing things to Github. The only thing Github should have is `-Werror` and friends. Signed-off-by: Jason Gerecke <jason.gerecke@wacom.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6e44fa9..86f30b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,8 @@ AC_PROG_LIBTOOL
# Compiler Flags / Libraries
# -----------------------------------------------------------------------------
m4_define(COMPILER_FLAGS, [
+ -Wall
+ -Wextra
-Wno-unused-parameter
-Wno-sign-compare dnl lots of work to get rid of this
-Wmissing-prototypes