summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-03-22 14:42:03 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2021-03-24 07:19:06 +1000
commitf38bc689e3045787c02dd1ad97fa5e7d6e1255bd (patch)
tree4c8c011b8f746a4b908057ccffca70b737b377af /meson.build
parent2e89a9d6b20c244d506764830c34b1c2cf184aee (diff)
downloadlibwacom-f38bc689e3045787c02dd1ad97fa5e7d6e1255bd.tar.gz
meson/autotools: always check for python
As of 0e17dff67bbb1772009adb5dc60035809a6fd329 we now require python to build the hwdb so let's check it early. This doesn't really have any effect on meson since meson itself is python, so the case of a missing python installation is a bit niche. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c7b1572..a0efc98 100644
--- a/meson.build
+++ b/meson.build
@@ -17,6 +17,9 @@ if dir_udev == ''
dir_udev = dir_sys_udev
endif
+pymod = import('python')
+python = pymod.find_installation('python3', required: true)
+
# Do not modify this, use symbol versioning instead.
libwacom_lt_c=8
libwacom_lt_r=1
@@ -294,8 +297,7 @@ if get_option('tests').enabled()
endif
if meson.version().version_compare('>= 0.51.0')
- python = import('python')
- python.find_installation(modules: ['libevdev', 'pyudev', 'pytest'])
+ pymod.find_installation(modules: ['libevdev', 'pyudev', 'pytest'])
endif
pytest = find_program('pytest-3', 'pytest')
test('pytest',