summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-04-28 14:33:05 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2021-04-28 15:08:48 +1000
commit94a5a93e049e6544029c3d68907e58b1d78a298c (patch)
tree6d1146e2f2a3ff8745e44d111ea88faaed562320 /meson.build
parentb6ed4c151b800ee03e2f112ad22a8d8316955ddc (diff)
downloadlibwacom-94a5a93e049e6544029c3d68907e58b1d78a298c.tar.gz
meson.build: rename the receiver ID test to just "pytest"
We'll end up running anything pytest collects, so let's have a more generic name. And replace a manual path composition with the existing variable here too. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7e5ab82..23a3803 100644
--- a/meson.build
+++ b/meson.build
@@ -139,9 +139,9 @@ test('svg-layout-exists',
# pytest-compatible test somewhere, we'll conveniently run that one too.
pytest = find_program('pytest-3', required: false)
if pytest.found()
- test('receiver-id-test', pytest,
+ test('pytests', pytest,
workdir: meson.source_root(),
- env: ['LIBWACOM_DATA_DIR=@0@'.format(join_paths(meson.source_root(), 'data'))])
+ env: ['LIBWACOM_DATA_DIR=@0@'.format(dir_src_data)])
endif
############### tools ###########################