summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-10-07 08:09:42 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2021-10-11 14:44:11 +1000
commit90d7a78d1b0a2d3faabc67f1ee65d9f2dbe64856 (patch)
tree8d6c2ef8192349733f4bea7c91875417b38856a9 /meson.build
parentd06634061b8d4e9470aafe9f6ebe15c582159cb0 (diff)
downloadlibwacom-90d7a78d1b0a2d3faabc67f1ee65d9f2dbe64856.tar.gz
meson.build: bump minimum version to 0.51
This allows us to get rid of one conditional, and 0.51 is over two years old by now anyway.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 1670c63..66fe96c 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@ project('libwacom', 'c',
version: '1.12', # change configure.ac as well
license: 'MIT/Expat',
default_options: [ 'c_std=gnu99', 'warning_level=2' ],
- meson_version: '>= 0.50.0')
+ meson_version: '>= 0.51.0')
dir_bin = get_option('prefix') / get_option('bindir')
dir_data = get_option('prefix') / get_option('datadir') / 'libwacom'
@@ -302,9 +302,7 @@ if get_option('tests').enabled()
suite: ['all'])
endif
- if meson.version().version_compare('>= 0.51.0')
- pymod.find_installation(modules: ['libevdev', 'pyudev', 'pytest'])
- endif
+ pymod.find_installation(modules: ['libevdev', 'pyudev', 'pytest'])
pytest = find_program('pytest-3', 'pytest')
test('pytest',
pytest,