summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-03-16 07:03:03 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2021-03-19 13:05:40 +1000
commit90267f32912c69d6b5524c22e0c2fe9ab2f62be4 (patch)
treea2e301a3d7b39a1fe11661aed21c5609d43658b2 /meson.build
parent3bfdd5041ef7f146fe26ddbe406a4c438f8e86c6 (diff)
downloadlibwacom-90267f32912c69d6b5524c22e0c2fe9ab2f62be4.tar.gz
tools: install our list-devices helper tool
Build it twice, once as list-devices, once as libwacom-list-devices. The former uses the source tree's data files, the latter the installed data files. Having this as installed tools makes it easier to debug situations where it's not clear whether the data file is picked up correctly or whether it's not applied correctly to the device. It also makes it easier to figure out "is this device supported by my libwacom version". Fixes #367 Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dae1162..76d2929 100644
--- a/meson.build
+++ b/meson.build
@@ -156,6 +156,7 @@ configure_file(input: 'tools/65-libwacom.rules.in',
install: true,
install_dir: join_paths(dir_udev, 'rules.d'))
+# The non-installed version of list-devices uses the git tree's data files
executable('list-devices',
'tools/list-devices.c',
dependencies: [dep_libwacom, dep_glib],
@@ -163,6 +164,13 @@ executable('list-devices',
c_args: tools_cflags,
install: false)
+# The installed version of list-devices uses the installed data files
+executable('libwacom-list-devices',
+ 'tools/list-devices.c',
+ dependencies: [dep_libwacom, dep_glib],
+ include_directories: [includes_src],
+ install: true)
+
executable('list-compatible-styli',
'tools/list-compatible-styli.c',
dependencies: [dep_libwacom, dep_glib],
@@ -174,6 +182,10 @@ install_man(configure_file(input: 'tools/libwacom-list-local-devices.man',
output: '@BASENAME@.1',
copy: true))
+install_man(configure_file(input: 'tools/libwacom-list-devices.man',
+ output: '@BASENAME@.1',
+ copy: true))
+
showstylus_config = configuration_data()
showstylus_config.set('DATADIR', dir_data)
showstylus_config.set('ETCDIR', dir_etc)