summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-09-15 11:16:45 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2020-10-07 17:41:36 +1000
commit800adfc0f62b4f93af098ee824e0a061dbb5059b (patch)
tree4c9e7edb128ebe32d46670fe175b8a432ea49498 /meson.build
parent8a7fee470983ad377f6d42211e6bb2f7f103c451 (diff)
downloadlibwacom-800adfc0f62b4f93af098ee824e0a061dbb5059b.tar.gz
meson.build: add a few more useful compiler warnings
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 15 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 7ae6e50..c98c07b 100644
--- a/meson.build
+++ b/meson.build
@@ -25,10 +25,21 @@ libwacom_so_version = '@0@.@1@.@2@'.format((libwacom_lt_c - libwacom_lt_a),
# Compiler setup
cc = meson.get_compiler('c')
-cflags= ['-Wno-unused-parameter',
- '-Wmissing-prototypes',
- '-Wstrict-prototypes',
- '-fvisibility=hidden']
+cflags = ['-Wno-unused-parameter',
+ '-Wmissing-prototypes',
+ '-Wstrict-prototypes',
+ '-Wundef',
+ '-Wlogical-op',
+ '-Wpointer-arith',
+ '-Wuninitialized',
+ '-Winit-self',
+ '-Wstrict-prototypes',
+ '-Wimplicit-fallthrough',
+ '-Wredundant-decls',
+ '-Wincompatible-pointer-types',
+ '-Wformat=2',
+ '-Wmissing-declarations',
+ '-fvisibility=hidden']
add_project_arguments(cflags, language: 'c')
# Dependencies