summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2021-03-25 08:56:11 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2021-03-25 13:32:39 +1000
commit06c1088342a349d7494dd8d86a7eca63e936494d (patch)
tree08816d493c110226e742ac0690026280e351a012 /meson.build
parent70e6090c4683065ae07f131adb5638a39ae9ee22 (diff)
downloadlibwacom-06c1088342a349d7494dd8d86a7eca63e936494d.tar.gz
Use g_memdup2 when we have it (meson only)
Check if we have g_memdup2 and where we don't have it, alias back to g_memdup() which is now deprecated in glib 2.68 and later. This is meson only, if you're running glib 2.68 from 2021, you can build with a modern buildsystem too. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d3d2c0c..8a3189d 100644
--- a/meson.build
+++ b/meson.build
@@ -59,6 +59,9 @@ includes_src = include_directories('libwacom')
# config.h
config_h = configuration_data()
+config_h.set10('HAVE_G_MEMDUP2',
+ cc.has_function('g_memdup2',
+ dependencies: dep_glib))
#################### libwacom.so ########################
src_libwacom = [