summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Wirzenius <lars.wirzenius@codethink.co.uk>2013-09-24 17:01:42 +0000
committerLars Wirzenius <lars.wirzenius@codethink.co.uk>2013-09-24 17:01:42 +0000
commitd25cc110f69e6e71a95b4ac532dcfc5423d4a16b (patch)
treed731aaa7579a46a30880eef3e36647797ad6515f /configure.ac
parentd234ccf15a897024bb004d0f3a9a2f3b8d0976e6 (diff)
parent5d23708442b16138b800a4e4e9daf20eda50ba46 (diff)
downloadlinux-user-chroot-d25cc110f69e6e71a95b4ac532dcfc5423d4a16b.tar.gz
Merge branch 'baserock/larswirzenius/update-to-master' into baserock/morphbaserock/morph
Reviewed-by: Jonathan Maw Reviewed-by: Daniel Silverstone
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index da5863f..4910b32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ([2.63])
-AC_INIT([linux-user-chroot], [3], [walters@verbum.org])
+AC_INIT([linux-user-chroot], [2013.1], [walters@verbum.org])
AC_CONFIG_HEADER([config.h])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR([build-aux])
@@ -8,6 +8,8 @@ AM_INIT_AUTOMAKE([1.11 -Wno-portability foreign no-define tar-ustar no-dist-gzip
AM_MAINTAINER_MODE([enable])
AM_SILENT_RULES([yes])
+AC_SYS_LARGEFILE
+
AC_PROG_CC
AM_PROG_CC_C_O
@@ -26,8 +28,11 @@ AC_CHECK_HEADER([linux/securebits.h],
[AC_DEFINE([HAVE_LINUX_SECUREBITS_H], [1],
[Define to 1 if we have securebits.h])])
-AC_PATH_PROG([XSLTPROC], [xsltproc])
-AM_CONDITIONAL(HAVE_XSLTPROC, test x"$XSLTPROC" != x)
+AC_ARG_ENABLE(documentation,
+ AC_HELP_STRING([--enable-documentation],
+ [build documentation]),,
+ enable_documentation=yes)
+AM_CONDITIONAL(BUILD_DOCUMENTATION, test x$enable_documentation = xyes)
AC_ARG_ENABLE(newnet-helper,
AC_HELP_STRING([--enable-newnet-helper],