summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorKirill Simonov <xi@resolvent.net>2006-05-21 14:58:32 +0000
committerKirill Simonov <xi@resolvent.net>2006-05-21 14:58:32 +0000
commit721c1923e49cc10cec9821d0877d94237265ca6f (patch)
tree6cb0f90ea5b674ef298fe24559856d575d55adb8 /include/Makefile.am
parentcec6fc98ebecc208edc30a900e6ab195e7c21851 (diff)
downloadlibyaml-hg-721c1923e49cc10cec9821d0877d94237265ca6f.tar.gz
Add doxygen support.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 29b04f3..5db6705 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1 +1,17 @@
-nobase_include_HEADERS = yaml/yaml.h yaml/yaml_version.h yaml/yaml_error.h
+INCLUDES = yaml/yaml.h yaml/yaml_version.h yaml/yaml_error.h
+DOXYGEN_CFG = $(top_srcdir)/doc/doxygen.cfg
+
+nobase_include_HEADERS = $(INCLUDES)
+
+if DOXYGEN
+
+html: $(INCLUDES) $(DOXYGEN_CFG)
+ PACKAGE=$(PACKAGE) VERSION=$(VERSION) top_srcdir=$(top_srcdir) top_builddir=$(top_builddir) doxygen $(DOXYGEN_CFG)
+
+endif
+
+distclean-local:
+ -rm -rf $(top_builddir)/doc/html
+
+dist-hook: html
+ cp -a $(top_builddir)/doc/html $(top_distdir)/doc