summaryrefslogtreecommitdiff
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2002-03-15 22:24:56 +0000
committerDaniel Veillard <veillard@src.gnome.org>2002-03-15 22:24:56 +0000
commitd2379010b1aa04ff87876d5b6dfd42ce2e12928f (patch)
treed0f5935d4451f0f3b549a8916fa44375e6485ed0 /python/Makefile.am
parente7dd2b8dc6fefba0142cfb2c77f3daf5f2236dfc (diff)
downloadlibxml2-d2379010b1aa04ff87876d5b6dfd42ce2e12928f.tar.gz
Cleanup of the python Makefiles based on Jacob and James feedback, fixed
* libxml.spec.in python/Makefile.am python/tests/Makefile.am python/generator.py python/libxml.c python/types.c: Cleanup of the python Makefiles based on Jacob and James feedback, fixed the spec file accordingly, fixed the number of warning that passing my pedantic CFLAGS was generating. Conclusion is that Python includes are real crap. Daniel
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am22
1 files changed, 8 insertions, 14 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 6078702d..1a188cbd 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -4,12 +4,12 @@ AUTOMAKE_OPTIONS = 1.4 foreign
SUBDIRS= . tests
INCLUDES = \
- -I/usr/include/python$(PYTHON_VERSION) \
-I$(PYTHON_INCLUDES) \
-I$(top_srcdir)/include
DOCS_DIR = $(prefix)/share/doc/libxml2-python-$(LIBXML_VERSION)
-DOCS = TODO libxml2class.txt
+# libxml2class.txt is generated
+DOCS = TODO
EXTRA_DIST = \
libxml.c \
@@ -22,24 +22,19 @@ EXTRA_DIST = \
libxml2-python-api.xml \
$(DOCS)
+libxml2mod_la_LDFLAGS = -module -avoid-version
+
if WITH_PYTHON
mylibs = \
$(top_builddir)/libxml2.la
-all: libxml2mod.so libxml2.py
+all: libxml2.py # libxml2mod.so
pythondir = $(prefix)/lib/python${PYTHON_VERSION}/site-packages
-python_PROGRAMS = libxml2mod.so
-
-libxml2mod_so_SOURCES =
-libxml2mod_so_LDFLAGS = $(mylibs) $(LIBS) -shared -Wl,-soname,libxml2mod.so
-
-noinst_LTLIBRARIES = libxmlmodule.la
-libxmlmodule_la_SOURCES = libxml.c types.c libxml2-py.c
-
-libxml2mod.so: $(libxmlmodule_la_OBJECTS) $(mylibs)
- $(LINK) -o $@ $(libxmlmodule_la_OBJECTS) $(libxml2mod_so_LDFLAGS)
+python_LTLIBRARIES = libxml2mod.la
+libxml2mod_la_SOURCES = libxml.c types.c libxml2-py.c
+libxml2mod_la_LIBADD = $(mylibs)
libxml2.py: $(srcdir)/libxml.py libxml2class.py
cat $(srcdir)/libxml.py libxml2class.py > libxml2.py
@@ -62,7 +57,6 @@ $(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
cd $(srcdir) && $(PYTHON) $(GENERATE)
$(libxmlmodule_la_OBJECTS): $(GENERATED)
-
else
all:
endif