summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFrederic Crozat <fcrozat@mandriva.com>2009-09-12 18:02:40 +0200
committerDaniel Veillard <veillard@redhat.com>2009-09-12 18:02:40 +0200
commite21731dec8da20f77f94481305a745990df57c9a (patch)
treebb9b13db7920508d210d0b5fc652595635441df4 /configure.in
parent84bff68e03824d14b0e2cd58167303ec0b13c840 (diff)
downloadlibxml2-e21731dec8da20f77f94481305a745990df57c9a.tar.gz
link python module with python library
* configure.in python/Makefile.am: libxml2 python module wasn't linked with python library
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7b8fd445..90d8b738 100644
--- a/configure.in
+++ b/configure.in
@@ -742,6 +742,7 @@ if test "$with_python" != "no" ; then
PYTHON_SITE_PACKAGES=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib()"`
fi
fi
+ PYTHON_LIBS=`python$PYTHON_VERSION-config --libs`
fi
if test "$with_python" != ""
then
@@ -761,6 +762,7 @@ else
fi
AC_SUBST(pythondir)
AC_SUBST(PYTHON_SUBDIR)
+AC_SUBST(PYTHON_LIBS)
dnl check for dso support
WITH_MODULES=0