summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2012-02-04 19:07:44 +0800
committerDaniel Veillard <veillard@redhat.com>2012-02-13 11:11:01 +0800
commit8973d58b7498fa5100a876815476b81fd1a2412a (patch)
tree598d84b675bbb249d9aa0a08765064037a9be000 /configure.in
parentadf5ec9496828b18e683fb23bd1e670824cfb6d0 (diff)
downloadlibxml2-8973d58b7498fa5100a876815476b81fd1a2412a.tar.gz
Add hash randomization to hash and dict structures
Following http://www.ocert.org/advisories/ocert-2011-003.html it seems that having hash randomization might be a good idea when using XML with untrusted data * configure.in: lookup for rand, srand and time * dict.c: add randomization to dictionaries hash tables * hash.c: add randomization to normal hash tables
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fa803750..828b66a9 100644
--- a/configure.in
+++ b/configure.in
@@ -512,6 +512,7 @@ AC_CHECK_FUNCS(strdup strndup strerror)
AC_CHECK_FUNCS(finite isnand fp_class class fpclass)
AC_CHECK_FUNCS(strftime localtime gettimeofday ftime)
AC_CHECK_FUNCS(stat _stat signal)
+AC_CHECK_FUNCS(rand srand time)
dnl Checking the standard string functions availability
AC_CHECK_FUNCS(printf sprintf fprintf snprintf vfprintf vsprintf vsnprintf sscanf,,