summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2017-05-31 19:06:30 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2017-06-01 14:31:28 +0200
commitac9a4560ee85b18811ff8ab7791ddfff7b144b0a (patch)
tree4290944162b91dc20372de91bd26bbc34302dc9a /Makefile.am
parentff34ba3e88cdd2e83e1c95e0356bbf4bef47ae2e (diff)
downloadlibxml2-ac9a4560ee85b18811ff8ab7791ddfff7b144b0a.tar.gz
Disable LeakSanitizer when running API tests
The autogenerated API tests leak memory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c64cee2..6fc8ffa9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -205,7 +205,12 @@ runxmlconf_LDADD= $(LDADDS)
runtests:
[ -d test ] || $(LN_S) $(srcdir)/test .
[ -d result ] || $(LN_S) $(srcdir)/result .
- $(CHECKER) ./runtest$(EXEEXT) && $(CHECKER) ./testrecurse$(EXEEXT) &&$(CHECKER) ./testapi$(EXEEXT) && $(CHECKER) ./testchar$(EXEEXT)&& $(CHECKER) ./testdict$(EXEEXT) && $(CHECKER) ./runxmlconf$(EXEEXT)
+ $(CHECKER) ./runtest$(EXEEXT) && \
+ $(CHECKER) ./testrecurse$(EXEEXT) && \
+ ASAN_OPTIONS="$$ASAN_OPTIONS:detect_leaks=0" $(CHECKER) ./testapi$(EXEEXT) && \
+ $(CHECKER) ./testchar$(EXEEXT) && \
+ $(CHECKER) ./testdict$(EXEEXT) && \
+ $(CHECKER) ./runxmlconf$(EXEEXT)
@(if [ "$(PYTHON_SUBDIR)" != "" ] ; then cd python ; \
$(MAKE) tests ; fi)
@@ -229,7 +234,7 @@ tests: XMLtests XMLenttests NStests IDtests Errtests APItests $(READER_TEST) $(T
APItests: testapi$(EXEEXT)
@echo "## Running the API regression tests this may take a little while"
- -@($(CHECKER) $(top_builddir)/testapi -q)
+ -@(ASAN_OPTIONS="$$ASAN_OPTIONS:detect_leaks=0" $(CHECKER) $(top_builddir)/testapi -q)
HTMLtests : testHTML$(EXEEXT)
@(echo > .memdump)