summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2017-11-12 18:22:23 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2017-11-14 16:03:36 +0100
commit8cb8e31773f9d148091cb71141c5ec4cd6b815df (patch)
tree63bb7997c2fe0826ee7f7c4995017b604a71cb44 /Makefile.am
parent00859f9118c59ba419dc08162438a0246af34659 (diff)
downloadlibxml2-8cb8e31773f9d148091cb71141c5ec4cd6b815df.tar.gz
Don't touch CFLAGS in configure.ac
CFLAGS shouldn't be touched by configure.ac. The variable is supplied by the user and must come after other flags, so flags like warning options can be overridden. Rename CFLAGS to EXTRA_CFLAGS and add the value to AM_CFLAGS. This also makes it possible to override flags for each Automake program or library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 748dfc2a..9c630be4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ DIST_SUBDIRS = include . doc example python xstc
AM_CPPFLAGS = -I$(top_builddir)/include -I$(srcdir)/include
-AM_CFLAGS = $(THREAD_CFLAGS) $(Z_CFLAGS) $(LZMA_CFLAGS)
+AM_CFLAGS = $(EXTRA_CFLAGS) $(THREAD_CFLAGS) $(Z_CFLAGS) $(LZMA_CFLAGS)
check_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
testThreads testC14N testAutomata testRegexp \