summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMattia Rizzolo <mattia@mapreri.org>2021-07-29 12:11:08 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2022-01-16 14:47:35 +0100
commit7c0253aadfe0ce69b077b66bf74fa26ff17728d1 (patch)
treee31b8356af53ea27e148711741be80f5cf02697c /Makefile.am
parent51c88c6f8d7b554847569fd6ba3e3b2aed646325 (diff)
downloadlibxml2-7c0253aadfe0ce69b077b66bf74fa26ff17728d1.tar.gz
Refactor the settings of $docdir
This is a completely noop change for this project, since before this commit nothing was using $docdir nor PROGRAM_TARNAME. Setting the fourth parameter of AC_INIT() makes it set PROGRAM_TARNAME, which then used as the last path component of the default docdir, effectively making $docdir be the same as the previous $BASE_DIR/$DOC_MODULE. Signed-off-by: Mattia Rizzolo <mattia@mapreri.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index a9284b95..716a17fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1273,13 +1273,11 @@ cmake_DATA = libxml2-config.cmake
#
# Install the tests program sources as examples
#
-BASE_DIR=$(datadir)/doc
-DOC_MODULE=libxml2-$(VERSION)
-EXAMPLES_DIR=$(BASE_DIR)/$(DOC_MODULE)/examples
+EXAMPLES_DIR=$(docdir)/examples
install-data-local:
- $(MKDIR_P) $(DESTDIR)$(BASE_DIR)/$(DOC_MODULE)
- -$(INSTALL) -m 0644 $(srcdir)/Copyright $(DESTDIR)$(BASE_DIR)/$(DOC_MODULE)
+ $(MKDIR_P) $(DESTDIR)$(docdir)
+ -$(INSTALL) -m 0644 $(srcdir)/Copyright $(DESTDIR)$(docdir)
$(MKDIR_P) $(DESTDIR)$(EXAMPLES_DIR)
-$(INSTALL) -m 0644 $(srcdir)/xmllint.c $(DESTDIR)$(EXAMPLES_DIR)
-$(INSTALL) -m 0644 $(srcdir)/testSAX.c $(DESTDIR)$(EXAMPLES_DIR)
@@ -1292,8 +1290,8 @@ uninstall-local:
rm -f $(DESTDIR)$(EXAMPLES_DIR)/testSAX.c
rm -f $(DESTDIR)$(EXAMPLES_DIR)/xmllint.c
rm -rf $(DESTDIR)$(EXAMPLES_DIR)
- rm -f $(DESTDIR)$(BASE_DIR)/$(DOC_MODULE)/Copyright
- rm -rf $(DESTDIR)$(BASE_DIR)/$(DOC_MODULE)
+ rm -f $(DESTDIR)$(docdir)/Copyright
+ rm -rf $(DESTDIR)$(docdir)
tst: tst.c
$(CC) $(CFLAGS) -Iinclude -o tst tst.c .libs/libxml2.a -lpthread -lm -lz -llzma