summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2005-08-22 12:58:05 +0000
committerDaniel Veillard <veillard@src.gnome.org>2005-08-22 12:58:05 +0000
commit355a023866e573462c65b2960491b1f5c6e3620b (patch)
tree4bcaf1999c344fae1e0dc9cf491b3788276460de /Makefile.am
parent465a000b1080427bd62d89a925409b7db78616ac (diff)
downloadlibxml2-355a023866e573462c65b2960491b1f5c6e3620b.tar.gz
added the first regression test suite set for the new expression support
* Makefile.am result/expr/base test/expr/base: added the first regression test suite set for the new expression support Daniel
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e1147b9d..ee09a7be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -822,6 +822,21 @@ Regexptests: testRegexp$(EXEEXT)
if [ -n "$$log" ] ; then echo $$name result ; echo $$log ; fi ; \
rm result.$$name ; \
fi ; fi ; done)
+ @echo "## Formal expresssions regression tests"
+ -@(for i in $(srcdir)/test/expr/* ; do \
+ name=`basename $$i`; \
+ if [ ! -d $$i ] ; then \
+ if [ ! -f $(srcdir)/result/expr/$$name ] ; then \
+ echo New test file $$name ; \
+ $(CHECKER) $(top_builddir)/testRegexp --expr -i $$i > $(srcdir)/result/expr/$$name; \
+ grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0";\
+ else \
+ log=`$(CHECKER) $(top_builddir)/testRegexp --expr -i $$i 2>&1 > result.$$name ; \
+ grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0";\
+ diff $(srcdir)/result/expr/$$name result.$$name` ; \
+ if [ -n "$$log" ] ; then echo $$name result ; echo $$log ; fi ; \
+ rm result.$$name ; \
+ fi ; fi ; done)
Automatatests: testAutomata$(EXEEXT)
@(echo > .memdump)