summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2008-08-28 15:36:32 +0000
committerDaniel Veillard <veillard@src.gnome.org>2008-08-28 15:36:32 +0000
commit0161e638c697890020c410dbedec9bb516d0fe49 (patch)
tree94453bdcdfaedf9e12ddd3a98e8ff37f847242b9 /Makefile.am
parent49d4405a6d76a91d61dbbd9e228bf31034c8da29 (diff)
downloadlibxml2-0161e638c697890020c410dbedec9bb516d0fe49.tar.gz
completely different fix for the recursion detection based on entity
* parser.c include/libxml/parser.h: completely different fix for the recursion detection based on entity density, big cleanups in the entity parsing code too * result/*.sax*: the parser should not ask for used defined versions of the predefined entities * testrecurse.c: automatic test for entity recursion checks * Makefile.am: added testrecurse * test/recurse/lol* test/recurse/good*: a first set of tests for the recursion Daniel svn path=/trunk/; revision=3783
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 49bd6f72..cc21bf9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,7 @@ INCLUDES = -I$(top_builddir)/include -I@srcdir@/include @THREAD_CFLAGS@ @Z_CFLAG
noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
testThreads testC14N testAutomata testRegexp \
testReader testapi testModule runtest runsuite testchar \
- testdict runxmlconf
+ testdict runxmlconf testrecurse
bin_PROGRAMS = xmllint xmlcatalog
@@ -56,6 +56,11 @@ runtest_LDFLAGS =
runtest_DEPENDENCIES = $(DEPS)
runtest_LDADD= @BASE_THREAD_LIBS@ @RDL_LIBS@ $(LDADDS)
+testrecurse_SOURCES=testrecurse.c
+testrecurse_LDFLAGS =
+testrecurse_DEPENDENCIES = $(DEPS)
+testrecurse_LDADD= @BASE_THREAD_LIBS@ @RDL_LIBS@ $(LDADDS)
+
testchar_SOURCES=testchar.c
testchar_LDFLAGS =
testchar_DEPENDENCIES = $(DEPS)