summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2022-09-20 14:30:19 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2022-09-20 14:30:19 +0200
commit796c830a2f113b73a81195b6fad8c66e66b4a751 (patch)
tree8f76e3248c3bbdbd85dc1ec322553b47665a4c2e /CMakeLists.txt
parent1d4f5d24ac3976012ab1f5b811385e7b00caaecf (diff)
downloadlibxml2-796c830a2f113b73a81195b6fad8c66e66b4a751.tar.gz
cmake: Set SOVERSION
Fixes #410.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b16af1f0..c3dba6c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -415,6 +415,7 @@ set_target_properties(
POSITION_INDEPENDENT_CODE ON
PREFIX lib
VERSION ${PROJECT_VERSION}
+ SOVERSION ${LIBXML_MAJOR_VERSION}
)
if(MSVC)