summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Untz <vuntz@gnome.org>2012-05-14 16:32:25 +0200
committerVincent Untz <vuntz@gnome.org>2012-05-14 16:37:17 +0200
commit21538b70a9d493d33021b806f830091591f66815 (patch)
treeb18e911c1c0f20401d56e31fdac4b584e5c44ff0 /configure.ac
parent59b2347b35df875ea2aa2653a30d3b07a36e8519 (diff)
downloadlibwnck-21538b70a9d493d33021b806f830091591f66815.tar.gz
build: Add --enable-tools to enable/disable installation of tools
This helps make libwnck 2.x and 3.x be parallel-installable since they conflict for wnckprop and wnck-urgency-monitor. https://bugzilla.gnome.org/show_bug.cgi?id=671558
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83df21b..082157d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,12 @@ if test "x$enable_deprecation_flags" = "xyes"; then
AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
fi
+AC_ARG_ENABLE(tools,
+ [AC_HELP_STRING([--enable-tools],
+ [install wnck-based tools @<:@default=yes@:>@])],,
+ [enable_tools=yes])
+AM_CONDITIONAL(ENABLE_TOOLS, test "x$enable_tools" != "xno")
+
GETTEXT_PACKAGE=libwnck-3.0
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Package name])
@@ -194,5 +200,6 @@ echo "
XRes support: ${have_xres}
Build introspection support: ${found_introspection}
Build gtk-doc documentation: ${enable_gtk_doc}
+ Install wnck-based tools: ${enable_tools}
"