summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorerikd <erikd@xiph.org>2009-02-04 22:19:14 +0000
committererikd <erikd@xiph.org>2009-02-04 22:19:14 +0000
commit3fdd3ddb050c263bee8111418b5f2b49349835a7 (patch)
treef2978ca1306aab63c0cc574ba8f046834810f930 /configure.ac
parent9a6b6286a711e37dd622640b5af9c311eeedab1d (diff)
downloadlibvorbis-git-3fdd3ddb050c263bee8111418b5f2b49349835a7.tar.gz
configure.ac : Fix --enable-docs logic which was badly broken.
svn path=/trunk/vorbis/; revision=15649
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 3451e237..6483aa93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,24 +61,19 @@ AM_PROG_CC_C_O
dnl docbook xml transform and processing tools
AC_ARG_ENABLE(docs,
- [ --enable-docs build the documentation],
- [case "${enableval}" in
- yes) build_docs=true;;
- no) build_docs=false;;
- *) AC_MSG_ERROR(unknown value ${enableval} for --enable-docs);;
- esac],[build_docs=false])
+ AC_HELP_STRING([--enable-docs], [build the documentation]))
dnl ideally we'd look for other tools and support them
-if test x$build_docs = xtrue; then
+if test x$enable_docs = xyes; then
AC_CHECK_PROGS([XSLTPROC], xsltproc, [/bin/false])
AC_CHECK_PROGS([PDFXMLTEX], pdfxmltex, [/bin/false])
if test "x$XSLTPROC" = "x/bin/false" || test "x$PDFXMLTEX" = "x/bin/false"; then
- build_docs=false
+ enable_docs=no
AC_MSG_WARN([Documentation will not be built!])
fi
fi
-AM_CONDITIONAL(BUILD_DOCS, [test x$build_docs = xtrue])
+AM_CONDITIONAL(BUILD_DOCS, [test x$enable_docs = xyes])
dnl --------------------------------------------------
dnl Set build flags based on environment