summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index af7db84..fc64399 100755
--- a/setup.py
+++ b/setup.py
@@ -313,6 +313,16 @@ class my_test(Command):
subprocess.check_call([pytest])
class my_clean(Command):
+ user_options = [
+ ('all', None, 'unused, compatibility with distutils')
+ ]
+
+ def initialize_options(self):
+ self.all = False
+
+ def finalize_options(self):
+ pass
+
def run(self):
if os.path.exists("build"):
shutil.rmtree("build", ignore_errors=True)