summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel P. Berrangé <berrange@redhat.com>2022-03-23 10:49:16 +0000
committerDaniel P. Berrangé <berrange@redhat.com>2022-04-21 12:34:06 +0100
commit88067eda52c3ad38a10ef96fb064f96dea01a374 (patch)
treed35f214f0998dfcdf36969c376bcc265a71fc7dd /setup.py
parent9d4b183b4edba47a6a5967e0d15fb256cede393e (diff)
downloadlibvirt-python-88067eda52c3ad38a10ef96fb064f96dea01a374.tar.gz
setup: replace distutils.dir_util.remove_tree with shutils
The distutils.dir_util.remove_tree method has no compelling benefit over using the standard python shutils module. Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index dceff34..d407532 100755
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,6 @@
from distutils.core import setup, Extension, Command
from distutils.command.build import build
from distutils.command.sdist import sdist
-from distutils.dir_util import remove_tree
from distutils.util import get_platform
import sys
@@ -298,7 +297,7 @@ class my_test(Command):
class my_clean(Command):
def run(self):
if os.path.exists("build"):
- remove_tree("build")
+ shutil.rmtree("build", ignore_errors=True)
##################