summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJim Fehlig <jfehlig@suse.com>2015-05-11 12:52:15 -0600
committerJim Fehlig <jfehlig@suse.com>2015-05-28 14:50:51 -0600
commit7211c4aaa3d91086a9e75281003e038f8d97e0ca (patch)
tree96efe755bb4a22111dc1a91f9f897b3fce67e50d /setup.py
parent06e8ea4702a3b054f4cc5a05dea9f9133a29c8d5 (diff)
downloadlibvirt-python-7211c4aaa3d91086a9e75281003e038f8d97e0ca.tar.gz
Fix duplicate entries in AUTHORSv1.2.16
The generated AUTHORS file contains many duplicates. If an author has N commits, there will be N entries for the author in AUTHORS. Check if an author already exists in the list before appending. While at it, add a .mailmap (derived from libivrt's .mailmap) to futher tidy the generated AUTHORS list.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2571742..7a1964b 100755
--- a/setup.py
+++ b/setup.py
@@ -176,7 +176,9 @@ class my_sdist(sdist):
f = os.popen("git log --pretty=format:'%aN <%aE>'")
authors = []
for line in f:
- authors.append(" " + line.strip())
+ line = " " + line.strip()
+ if line not in authors:
+ authors.append(line)
authors.sort(key=str.lower)