summaryrefslogtreecommitdiff
path: root/debian.upstream
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-08-25 11:42:27 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-08-25 14:28:40 +0200
commit8d884f8a7a7dd1983cb595880f68899cbb3425a4 (patch)
tree3bfeaa81b6634ec33c74b04a7e4ff082327f089d /debian.upstream
parentda2f0a4021d81530ce057f7cfbf560e5eb5c3bdd (diff)
downloadlibva-intel-driver-8d884f8a7a7dd1983cb595880f68899cbb3425a4.tar.gz
Add debian packaging.
Diffstat (limited to 'debian.upstream')
-rw-r--r--debian.upstream/Makefile.am28
-rw-r--r--debian.upstream/changelog.in5
-rw-r--r--debian.upstream/compat1
-rw-r--r--debian.upstream/control.in28
-rw-r--r--debian.upstream/copyright25
-rw-r--r--debian.upstream/libva-driver-intel.install1
-rwxr-xr-xdebian.upstream/rules15
7 files changed, 103 insertions, 0 deletions
diff --git a/debian.upstream/Makefile.am b/debian.upstream/Makefile.am
new file mode 100644
index 00000000..4363ac7f
--- /dev/null
+++ b/debian.upstream/Makefile.am
@@ -0,0 +1,28 @@
+DEBIANFILES = \
+ changelog.in \
+ compat \
+ control.in \
+ copyright \
+ libva-driver-intel.install \
+ rules \
+ $(NULL)
+
+DEBIANGENFILES = \
+ changelog \
+ control \
+ $(NULL)
+
+EXTRA_DIST = $(DEBIANFILES)
+
+dist_noinst_DATA = $(DEBIANGENFILES)
+
+# Extra clean files so that maintainer-clean removes *everything*
+MAINTAINERCLEANFILES = Makefile.in $(DEBIANGENFILES)
+
+$(DEBIANGENFILES): %: %.in Makefile
+ -sed \
+ -e 's|\@DATE\@|'"`LC_ALL=C date +'%a, %d %b %Y %X %z'`"'|' \
+ -e 's|\@LIBDRM_VERSION\@|$(LIBDRM_VERSION)|' \
+ -e 's|\@LIBVA_PACKAGE_VERSION\@|$(LIBVA_PACKAGE_VERSION)|' \
+ -e 's|\@PACKAGE_VERSION\@|$(PACKAGE_VERSION)|' \
+ $< > $@
diff --git a/debian.upstream/changelog.in b/debian.upstream/changelog.in
new file mode 100644
index 00000000..70310b55
--- /dev/null
+++ b/debian.upstream/changelog.in
@@ -0,0 +1,5 @@
+libva-driver-intel (@PACKAGE_VERSION@-1) unstable; urgency=low
+
+ * Autogenerated package, see NEWS file for ChangeLog.
+
+ -- Gwenole Beauchesne <gwenole.beauchesne@intel.com> @DATE@
diff --git a/debian.upstream/compat b/debian.upstream/compat
new file mode 100644
index 00000000..7ed6ff82
--- /dev/null
+++ b/debian.upstream/compat
@@ -0,0 +1 @@
+5
diff --git a/debian.upstream/control.in b/debian.upstream/control.in
new file mode 100644
index 00000000..88ee9280
--- /dev/null
+++ b/debian.upstream/control.in
@@ -0,0 +1,28 @@
+Source: libva-driver-intel
+Section: libs
+Priority: optional
+Maintainer: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
+Build-Depends: debhelper (>= 5),
+ cdbs,
+ libdrm-dev (>= @LIBDRM_VERSION@),
+ libva-dev (>= @LIBVA_PACKAGE_VERSION@)
+Standards-Version: 3.7.2
+
+Package: libva-driver-intel
+Section: libs
+Architecture: any
+Depends: libva1 (>= @LIBVA_PACKAGE_VERSION@),
+ ${shlibs:Depends}, ${misc:Depends}
+Description: VA driver for Intel G45 & HD Graphics family
+ Video decode & encode driver for Intel G45 chipsets and Intel HD
+ Graphics for Intel Core processor family.
+
+Package: libva-driver-intel-dbg
+Section: libdevel
+Architecture: any
+Depends: libva-driver-intel (= ${Source-Version})
+Description: VA driver for Intel G45 & HD Graphics family (debug symbols)
+ Video decode & encode driver for Intel G45 chipsets and Intel HD
+ Graphics for Intel Core processor family.
+ .
+ This package contains the debug files.
diff --git a/debian.upstream/copyright b/debian.upstream/copyright
new file mode 100644
index 00000000..8f3c4c38
--- /dev/null
+++ b/debian.upstream/copyright
@@ -0,0 +1,25 @@
+This package is maintained by:
+Gwenole Beauchesne <gwenole.beauchesne@intel.com>
+
+
+License:
+
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish,
+ distribute, sub license, and/or sell copies of the Software, and to
+ permit persons to whom the Software is furnished to do so, subject to
+ the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial portions
+ of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
+ IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS SUPPLIERS BE LIABLE FOR
+ ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/debian.upstream/libva-driver-intel.install b/debian.upstream/libva-driver-intel.install
new file mode 100644
index 00000000..daa01dcd
--- /dev/null
+++ b/debian.upstream/libva-driver-intel.install
@@ -0,0 +1 @@
+debian/tmp/usr/lib/dri/*.so
diff --git a/debian.upstream/rules b/debian.upstream/rules
new file mode 100755
index 00000000..27b26393
--- /dev/null
+++ b/debian.upstream/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+# Allow SMP build
+ifeq ($(DEBIAN_BUILD_NCPUS),)
+ DEBIAN_BUILD_NCPUS = $(shell /usr/bin/getconf _NPROCESSORS_ONLN)
+endif
+ifneq ($(DEBIAN_BUILD_NCPUS),)
+ EXTRA_MAKE_FLAGS += -j$(DEBIAN_BUILD_NCPUS)
+endif
+MAKE += $(EXTRA_MAKE_FLAGS)