summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSean V Kelley <seanvk@posteo.de>2017-02-04 00:04:44 -0800
committerSean V. Kelley <seanvk@users.noreply.github.com>2017-02-04 10:07:49 -0800
commit9316174fca7a8560158beed822020eaf4d30eefd (patch)
tree28c9328a5a599218936fbc307e65cd37900df9d1 /configure.ac
parenta37b527a20c52d7da2feb95ad2b18596faa94fa4 (diff)
downloadlibva-intel-driver-9316174fca7a8560158beed822020eaf4d30eefd.tar.gz
config: Explicitly handle wayland-client pkgconfig
Ensure deps are more robustly covered. fixes #29 Signed-off-by: Sean V Kelley <seanvk@posteo.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b31afef1..90dffd11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -188,6 +188,8 @@ if test "$enable_wayland" = "yes"; then
if test "$USE_WAYLAND" = "yes"; then
+ PKG_CHECK_MODULES([WAYLAND_CLIENT], [wayland-client],
+ [INCLUDES="$INCLUDES $WAYLAND_CLIENT_CFLAGS"], [:])
WAYLAND_PREFIX=`$PKG_CONFIG --variable=prefix wayland-client`
AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner],,
[${WAYLAND_PREFIX}/bin$PATH_SEPARATOR$PATH])