summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorU. Artie Eoff <ullysses.a.eoff@intel.com>2016-09-01 12:59:36 -0700
committerXiang, Haihao <haihao.xiang@intel.com>2016-10-31 09:58:56 +0800
commit3d1ab07ef9d315bb278210a6a511739f324006fe (patch)
tree61daeed668c9a0178b22f3f0335b5cd7403d0386 /configure.ac
parenta913a286a10d2fe3450958737929e1c8fa520df3 (diff)
downloadlibva-intel-driver-3d1ab07ef9d315bb278210a6a511739f324006fe.tar.gz
toolchain: build gtest convenience library
Define autoconf/automake rules to build libgtest.la as a convenience library. Add --enable-tests configure option (default:no). Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com> Reviewed-by: Sean V Kelley <seanvk@posteo.de> (cherry picked from commit b6906974929e778400c2a84dba8ebf2a2a3f68f4)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2f1bccf5..2e744678 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,11 +61,16 @@ AC_ARG_ENABLE([hybrid-codec],
[build with hybrid codec support @<:@default=no@:>@])],
[], [enable_hybrid_codec="no"])
+AC_ARG_ENABLE([tests],
+ [AC_HELP_STRING([--enable-tests],
+ [build tests @<:@default=no@:>@])],
+ [], [enable_tests="no"])
+
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CC
AM_PROG_CC_C_O
-
+AC_PROG_CXX
AC_C_BIGENDIAN
AC_HEADER_STDC
AC_SYS_LARGEFILE
@@ -116,6 +121,8 @@ if test "$enable_hybrid_codec" = "yes"; then
AC_DEFINE([HAVE_HYBRID_CODEC], [1], [Defined to 1 if hybrid codec is needed])
fi
+AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" = "yes")
+
VA_VERSION=`$PKG_CONFIG --modversion libva`
VA_MAJOR_VERSION=`echo "$VA_VERSION" | cut -d'.' -f1`
VA_MINOR_VERSION=`echo "$VA_VERSION" | cut -d'.' -f2`
@@ -207,6 +214,7 @@ AC_OUTPUT([
src/shaders/render/Makefile
src/shaders/utils/Makefile
src/shaders/vme/Makefile
+ test/Makefile
])
dnl Print summary
@@ -221,4 +229,5 @@ echo
echo VA-API version ................... : $VA_VERSION_STR
echo VA-API drivers path .............. : $LIBVA_DRIVERS_PATH
echo Windowing systems ................ : $BACKENDS
+echo Build tests ...................... : $enable_tests
echo