summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Charles <daniel.charles@intel.com>2017-02-21 15:31:46 -0800
committerSean V. Kelley <seanvk@users.noreply.github.com>2017-02-22 17:26:17 -0800
commit03a86fc527febd7a2f2d52d3b46fee2c5ccb641b (patch)
treeafb660074d05e7368777c399d7ff2e27a3c52026 /configure.ac
parent9072556e0735076f5bf96a40a9f5de15300a2de2 (diff)
downloadlibva-intel-driver-03a86fc527febd7a2f2d52d3b46fee2c5ccb641b.tar.gz
configure: check for x11 on path
enable-x11 is set to yes by default and during configuration it has to check for X11 header files on the path then the build system is prepared to avoid compiling X11 related code if headers are not present. Fixes #48 TEST="autogen.sh --prefix=<some prefix>, make sure X11 headers are not installed" TEST="x11 should not print out as supported on the configure summary" Signed-off-by: Daniel Charles <daniel.charles@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 226df540..16129930 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,6 +142,15 @@ AC_DEFINE_UNQUOTED([VA_DRIVER_INIT_FUNC], [$VA_DRIVER_INIT_FUNC],
dnl Check for VA/DRM API
USE_X11="$enable_x11"
+
+dnl Check for X11
+if test "$enable_x11" = "yes"; then
+ USE_X11="yes"
+ PKG_CHECK_MODULES([X11], [x11], [:], [USE_X11="no"])
+ PKG_CHECK_MODULES([XEXT], [xext], [:], [USE_X11="no"])
+ PKG_CHECK_MODULES([XFIXES], [xfixes], [:], [USE_X11="no"])
+fi
+
if test "$USE_X11" = "yes"; then
PKG_CHECK_MODULES(LIBVA_X11_DEPS, [libva-x11],
[AC_DEFINE([HAVE_VA_X11], [1], [Defined to 1 if VA/X11 API is enabled])],