summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e578a58..8d3ba9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([libusb], [1.0.5])
+AC_INIT([libusb], [1.0.6])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([libusb/core.c])
AC_CONFIG_MACRO_DIR([m4])
@@ -11,6 +11,7 @@ AC_PROG_LIBTOOL
AC_C_INLINE
AM_PROG_CC_C_O
AC_DEFINE([_GNU_SOURCE], [], [Use GNU extensions])
+AC_DEFINE([POSIX_THREADS], [], [Posix Threads])
AC_MSG_CHECKING([operating system])
case $host in
@@ -19,6 +20,7 @@ case $host in
AC_SUBST(OS_LINUX)
AC_MSG_RESULT([Linux])
backend="linux"
+ threads="posix"
AC_CHECK_LIB(rt, clock_gettime)
AM_CFLAGS="-pthread -Wshadow"
AM_LDFLAGS=""
@@ -29,6 +31,7 @@ case $host in
AC_DEFINE(USBI_OS_HANDLES_TIMEOUT, [], [Backend handles timeout])
AC_MSG_RESULT([Darwin/MacOS X])
backend="darwin"
+ threads="posix"
AM_CFLAGS="-pthread -Wshadow"
AM_LDFLAGS="-Wl,-framework -Wl,IOKit -Wl,-framework -Wl,CoreFoundation -Wl,-prebind -no-undefined"
;;
@@ -37,7 +40,8 @@ case $host in
AC_SUBST(OS_WINDOWS)
AC_MSG_RESULT([Windows])
backend="windows"
- LIBS="-lpthreadGC2 -lsetupapi -lole32"
+ threads="windows"
+ LIBS="-lsetupapi -lole32"
AM_CFLAGS="-Wshadow"
AM_LDFLAGS="-no-undefined"
;;
@@ -46,6 +50,7 @@ case $host in
AC_SUBST(OS_WINDOWS)
AC_MSG_RESULT([Windows])
backend="windows"
+ threads="posix"
LIBS="-lpthread -lsetupapi -lole32"
AM_CFLAGS=""
AM_LDFLAGS="-no-undefined"
@@ -57,6 +62,7 @@ esac
AM_CONDITIONAL([OS_LINUX], [test "x$backend" == "xlinux"])
AM_CONDITIONAL([OS_DARWIN], [test "x$backend" == "xdarwin"])
AM_CONDITIONAL([OS_WINDOWS], [test "x$backend" == "xwindows"])
+AM_CONDITIONAL([POSIX_THREADS], [test "x$threads" == "xposix"])
# Library versioning
lt_major="0"