summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorToby Gray <toby.gray@realvnc.com>2012-11-21 14:00:31 +0000
committerPete Batard <pete@akeo.ie>2012-11-25 01:32:59 +0000
commit21cf6e4748c20644c259d6f4271d2ca67d2e42e8 (patch)
treedf0506ab131c067ac0d7bc9abdb6c5c6d88664bc /configure.ac
parent94b0ccc5e58b854c7e9e38b21efd3d217f0f5353 (diff)
downloadlibusb-21cf6e4748c20644c259d6f4271d2ca67d2e42e8.tar.gz
Tests: Add libusbx stress test
See https://github.com/tobygray/libusbx/tree/testing as well as http://libusbx.1081486.n5.nabble.com/Libusbx-devel-Crashes-tt433.html#a438
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ba6ef5..ac41218 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,6 +186,13 @@ AC_ARG_ENABLE([examples-build], [AS_HELP_STRING([--enable-examples-build],
[build_examples='no'])
AM_CONDITIONAL([BUILD_EXAMPLES], [test "x$build_examples" != "xno"])
+# Tests build
+AC_ARG_ENABLE([tests-build], [AS_HELP_STRING([--enable-tests-build],
+ [build test applications (default n)])],
+ [build_tests=$enableval],
+ [build_tests='no'])
+AM_CONDITIONAL([BUILD_TESTS], [test "x$build_tests" != "xno"])
+
# check for -fvisibility=hidden compiler support (GCC >= 3.4)
saved_cflags="$CFLAGS"
# -Werror required for cygwin
@@ -222,6 +229,7 @@ AC_CONFIG_FILES([libusb-1.0.pc])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([libusb/Makefile])
AC_CONFIG_FILES([examples/Makefile])
+AC_CONFIG_FILES([tests/Makefile])
AC_CONFIG_FILES([doc/Makefile])
AC_CONFIG_FILES([doc/doxygen.cfg])
AC_OUTPUT