summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSameeh Jubran <sameeh@daynix.com>2017-01-15 11:40:57 +0200
committerChris Dickens <christopher.a.dickens@gmail.com>2018-01-08 10:18:09 -0800
commit020103af78c55a9e0d01fbabecbd4d2108801c4a (patch)
tree80e7cde2e812e6d15b3a3b5596b7caeb0d278f9f /configure.ac
parent54884e84d024e761450287ab56aca8fc69f45d01 (diff)
downloadlibusb-020103af78c55a9e0d01fbabecbd4d2108801c4a.tar.gz
Windows: Ditch UsbDk build configuration
Previous patch introduced run-time UsbDk backend activation, therefore separate build configuration is not needed anymore. Signed-off-by: Sameeh Jubran <sameeh@daynix.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index b596eae..5b16c68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -178,14 +178,6 @@ windows)
AC_DEFINE([POLL_NFDS_TYPE],[unsigned int],[type of second poll() argument])
AC_DEFINE([WINVER], 0x0501, [Oldest Windows version supported])
AC_DEFINE([_WIN32_WINNT], 0x0501, [Oldest Windows version supported])
-
- AC_ARG_ENABLE([usbdk],
- [AC_HELP_STRING([--enable-usbdk], [use UsbDk Windows backend [default=no]])],
- [], [enable_usbdk=no])
- if test "x$enable_usbdk" = xyes; then
- AC_DEFINE(USE_USBDK, 1, [Use UsbDk Windows backend])
- fi
- AC_SUBST(USE_USBDK)
;;
haiku)
AC_DEFINE(OS_HAIKU, 1, [Haiku backend])
@@ -208,7 +200,6 @@ AM_CONDITIONAL(OS_HAIKU, test "x$backend" = xhaiku)
AM_CONDITIONAL(THREADS_POSIX, test "x$threads" = xposix)
AM_CONDITIONAL(CREATE_IMPORT_LIB, test "x$create_import_lib" = xyes)
AM_CONDITIONAL(USE_UDEV, test "x$enable_udev" = xyes)
-AM_CONDITIONAL(USE_USBDK, test "x$enable_usbdk" = xyes)
if test "x$threads" = xposix; then
AC_DEFINE(THREADS_POSIX, 1, [Use POSIX Threads])
fi