summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2838c186..c0741070 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -57,7 +57,6 @@ endif
Gtest-resume-sig Ltest-resume-sig \
Gtest-resume-sig-rt Ltest-resume-sig-rt \
Gtest-trace Ltest-trace \
- Ltest-init-local-signal \
Ltest-mem-validate \
test-async-sig test-flush-cache test-init-remote \
test-mem test-reg-state Ltest-varargs \
@@ -65,6 +64,11 @@ endif
noinst_PROGRAMS_cdep += forker Gperf-simple Lperf-simple \
Gperf-trace Lperf-trace
+# unw_init_local2() is not implemented on ia64
+if !ARCH_IA64
+ check_PROGRAMS_cdep += Ltest-init-local-signal
+endif
+
if BUILD_PTRACE
check_SCRIPTS_cdep += run-ptrace-mapper run-ptrace-misc
check_PROGRAMS_cdep += test-ptrace