summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStephen Webb <swebb@blackberry.com>2022-06-03 13:36:27 -0400
committerStephen M. Webb <stephen.webb@bregmasoft.ca>2022-06-23 22:36:03 -0400
commit2f8693a1d62f23ebeb21e45593a9f88d0a34bac5 (patch)
tree13068d79c238b3128ce4571f438130f40b5589bb /tests/Makefile.am
parent860f0fe9adac2fdb384a11e072fc4e7463c6cd7d (diff)
downloadlibunwind-2f8693a1d62f23ebeb21e45593a9f88d0a34bac5.tar.gz
Allow an alternate LOG_DRIVER to be specified
Specifying --with-testdriver=TESTDRIVER at configure time allows the substitution of a alternative LOG_DRIVER to be specified to enable remote testing of a cross-built target. See the automake docuemntation on Custom Test Drivers for more information.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c783fc31..fa867367 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,8 @@
AM_CPPFLAGS = -I$(top_srcdir)/include
AM_CFLAGS = -fno-optimize-sibling-calls
+LOG_DRIVER = $(SHELL) $(UNW_TESTDRIVER)
+
EXTRA_DIST = run-ia64-test-dyn1 run-ptrace-mapper run-ptrace-misc \
run-check-namespace run-coredump-unwind \
run-coredump-unwind-mdi check-namespace.sh.in \