summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThierry Reding <treding@nvidia.com>2014-06-27 08:40:33 +0200
committerArun Sharma <arun@sharma-home.net>2014-08-15 13:01:29 -0700
commitf1684379dfaf8018d5d4c1945e292a56d0fab245 (patch)
treef79c28128799884c48150a5913b31d8b39049b58 /configure.ac
parent65ac86741606e1d87aef75755c699e4fa6884230 (diff)
downloadlibunwind-f1684379dfaf8018d5d4c1945e292a56d0fab245.tar.gz
Link libunwind to libgcc_s rather than libgcc
For some architectures, -lgcc and -lgcc_s are not equivalent. On ARM for example, libgcc_s.so.1 contains some symbols needed by libunwind which are not present in libgcc. This causes the following link error when building the X.Org X server with libunwind support: CCLD Xorg /usr/lib/libunwind.so: undefined reference to `__aeabi_unwind_cpp_pr0' /usr/lib/libunwind.so: undefined reference to `__aeabi_unwind_cpp_pr1' Linking against libgcc_s explicitly solves this problem. Signed-off-by: Thierry Reding <treding@nvidia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4e2fd236..a77cf01e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,7 +307,7 @@ else
fi
if test x$GCC = xyes -a x$intel_compiler != xyes -a x$qcc_compiler != xyes; then
- LIBCRTS="-lgcc"
+ LIBCRTS="-lgcc_s"
fi
AC_MSG_CHECKING([for __builtin___clear_cache])