summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Webb <swebb@blackberry.com>2022-08-10 09:57:09 -0400
committerStephen M. Webb <stephen.webb@bregmasoft.ca>2022-08-13 11:00:06 -0400
commit778dc30fbfc9da43e9637dd06ea4d019eae0e1bd (patch)
treea83fd23745536f02f60653cb8d58b2abf713a92f /configure.ac
parent9afaef970b69c8f7e9194bb9956ba57215e97a4a (diff)
downloadlibunwind-778dc30fbfc9da43e9637dd06ea4d019eae0e1bd.tar.gz
Stop the autotools nag about AC_CONFIG_MACRO_DIRS
All warnings should be heeded, including the ones spat out by autoreconf. In this case, autoconf wanted a place to generate its m4 files into and automake wanted the right target names in doc/Makefile.am. Also added AM_SILENT_FILES([yes]) to reduce the visual noise in build output to make spotting build problems easier. You can override the silent default by running `make` with `V=0` appended to the command line. Removed the unnecessary and unused acinclude.m4 file to reduce clutter in the source directory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f535c86c..b3be39d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,14 +1,18 @@
+dnl Process this file with autoconf to produce a configure script.
+
define(pkg_major, 1)
define(pkg_minor, 6)
define(pkg_extra, -rc1)
define(pkg_maintainer, libunwind-devel@nongnu.org)
define(mkvers, $1.$2$3)
-dnl Process this file with autoconf to produce a configure script.
+
AC_INIT([libunwind],[mkvers(pkg_major, pkg_minor, pkg_extra)],[pkg_maintainer])
AC_CONFIG_SRCDIR(src/mi/backtrace.c)
AC_CONFIG_AUX_DIR(config)
+AC_CONFIG_MACRO_DIRS([m4])
AC_CANONICAL_TARGET
-AM_INIT_AUTOMAKE([1.6 subdir-objects])
+AM_INIT_AUTOMAKE([1.6 subdir-objects -Wall])
+AM_SILENT_RULES([yes])
AM_MAINTAINER_MODE
AC_CONFIG_HEADERS([include/config.h])