summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Webb <swebb@blackberry.com>2020-06-11 17:52:49 -0400
committerDave Watson <dade.watson@gmail.com>2020-06-18 13:42:19 -0700
commit12e70a59df9a2e1c436c79c1dba941ca555db843 (patch)
treed0f9cc95ba9c54d22f8de5fbbf731f076ebadd5c /configure.ac
parent77dfbd60e715399f06b3e823fdffa5d9c658caf2 (diff)
downloadlibunwind-12e70a59df9a2e1c436c79c1dba941ca555db843.tar.gz
Rationalize endianness macros
Extend the endianness macros to support systems that define them in <sys/param.h> and replace the use of names that violate ISO/IEC 9899. Rename endianness macros used in code to use properly-namespaced macros for portability and cross-hosting compatibility. Add inline functions to perform common operations with the macros.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b85c37bd..c5470d8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,8 +34,8 @@ esac
dnl Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(asm/ptrace_offsets.h endian.h sys/endian.h execinfo.h \
- ia64intrin.h sys/uc_access.h unistd.h signal.h sys/types.h \
+AC_CHECK_HEADERS(asm/ptrace_offsets.h endian.h sys/endian.h sys/param.h \
+ execinfo.h ia64intrin.h sys/uc_access.h unistd.h signal.h sys/types.h \
sys/procfs.h sys/ptrace.h byteswap.h elf.h sys/elf.h link.h sys/link.h)
dnl Checks for typedefs, structures, and compiler characteristics.