summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zwelch@codesourcery.com>2010-10-28 16:25:51 -0700
committerArun Sharma <aruns@google.com>2010-11-08 09:06:09 -0800
commit651e9bb4fdef2f6f4dbdb4f85bee071ef72bcd25 (patch)
treea9c57941c6459fd5500bcc212333edcd8d1eac3b /Makefile.am
parent3ac945b7ee32288bda667067095ad15498a14845 (diff)
downloadlibunwind-651e9bb4fdef2f6f4dbdb4f85bee071ef72bcd25.tar.gz
Add MAINTAINERCLEANFILES to Makefile.am files.
Ensures 'make maintainer-clean' removes files generated by autotools. Signed-off-by: Zachary T Welch <zwelch@codesourcery.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a7de2fb4..9484c972 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -65,3 +65,18 @@ EXTRA_DIST = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
include/tdep-ppc64/jmpbuf.h include/tdep-ppc64/libunwind_i.h \
include/libunwind.h include/tdep/libunwind_i.h \
include/tdep/jmpbuf.h include/tdep/dwarf-config.h
+
+MAINTAINERCLEANFILES = \
+ Makefile.in \
+ INSTALL \
+ aclocal.m4 \
+ configure \
+ config/compile \
+ config/config.guess \
+ config/config.sub \
+ config/depcomp \
+ config/install-sh \
+ config/ltmain.sh \
+ config/missing \
+ include/config.h.in \
+ include/config.h.in~