summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2019-07-01 04:59:56 +0200
committerBruno Haible <bruno@clisp.org>2019-07-01 04:59:56 +0200
commitc5b665df10effdd8680c9e37fe73c9171ad1bee2 (patch)
treeaef2d6e5276b236f0d1d26b12bbdf11ab397c7db /lib/Makefile.am
parent1fd6790a8c3698336399acd0504b2e470eca8789 (diff)
downloadlibunistring-c5b665df10effdd8680c9e37fe73c9171ad1bee2.tar.gz
build: Fix build errors with MSVC.
* lib/exported.sh.in: Remove one level of eval. * lib/Makefile.am (config.h): Redirect compiler output to stderr. Remove symbols that contain an '@'.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 4e8f3f3..640b2cb 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -302,8 +302,8 @@ config.h: $(BUILT_SOURCES) $(srcdir)/libunistring.sym
;; \
esac; \
done; \
- } 5>&1 \
- | sed -e 's,.* ,,' | LC_ALL=C sort | LC_ALL=C uniq \
+ } 5>&1 1>&2 \
+ | sed -e 's,.* ,,' | grep -v '@' | LC_ALL=C sort | LC_ALL=C uniq \
| LC_ALL=C join -v 1 - $(srcdir)/libunistring.sym \
| grep -v '^libintl_locale' \
| sed -e 's,^\(.*\)$$,#define \1 libunistring_\1,' > config.h-t; \