summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-04-22 04:55:25 +0200
committerBruno Haible <bruno@clisp.org>2009-04-22 04:55:25 +0200
commit5f755fddada02a264f6381974a564538950fb54a (patch)
tree9d5897918b228d3753ede01f0af977c40a58e9fc /lib/Makefile.am
parent7550f78f9b88f77309b1a233df6ef1f0e94f3035 (diff)
downloadlibunistring-5f755fddada02a264f6381974a564538950fb54a.tar.gz
Add version metainformation in Windows resource format.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 19b7562..40704fd 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -203,6 +203,7 @@ config.h: $(BUILT_SOURCES) libunistring.sym
{ \
for f in $(libunistring_la_SOURCES) $(libunistring_la_LIBADD); do \
case $$f in \
+ *.res.lo ) ;; \
*.c | *.$(OBJEXT) | *.lo ) \
sf=`echo "$$f" | sed -e 's,\\.[^.]*$$,,'`.c; \
test -f $$sf || sf=$(srcdir)/$$sf; \
@@ -227,6 +228,19 @@ config.h: $(BUILT_SOURCES) libunistring.sym
fi
MOSTLYCLEANFILES += config.h config.h-t
+# Version information according to Woe32 conventions.
+EXTRA_DIST += libunistring.rc
+if WOE32
+WOE32_LIBADD = libunistring.res.lo
+libunistring.res.lo : $(srcdir)/libunistring.rc
+ $(LIBTOOL) --tag=RC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(RC) `$(SHELL) $(top_srcdir)/build-aux/windres-options --escape $(VERSION)` -i $(srcdir)/libunistring.rc -o libunistring.res.lo --output-format=coff
+MOSTLYCLEANFILES += libunistring.res.lo
+else
+WOE32_LIBADD =
+endif
+libunistring_la_LIBADD += $(WOE32_LIBADD)
+libunistring_la_DEPENDENCIES += $(WOE32_LIBADD)
+
# Libtool's library version information for libunistring.
# See the libtool documentation, section "Library interface versions".
LTV_CURRENT=0