summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-12-25 02:50:56 +0100
committerBruno Haible <bruno@clisp.org>2009-12-25 02:50:56 +0100
commit43e5d6dc390ec27ed97002f9eb33aa5903b73c81 (patch)
tree13c5a11bbe2a74f501fe0729744204f531756361 /lib/Makefile.am
parent4b8650c5e098e010b1468430e5e9cf4f5b71ba76 (diff)
downloadlibunistring-43e5d6dc390ec27ed97002f9eb33aa5903b73c81.tar.gz
Update after gnulib added module 'unused-parameter'.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index f9efa8f..5d58942 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -157,6 +157,16 @@ nobase_nodist_include_HEADERS += unistring/version.h
# unistring/cdefs.h is not public, but is included by other header files.
nobase_nodist_include_HEADERS += unistring/cdefs.h
+unistring/cdefs.h : unistring/cdefs.in.h
+ @MKDIR_P@ unistring
+ rm -f $@-t $@
+ sed -e '/definition of _GL_UNUSED_PARAMETER/r $(UNUSED_PARAMETER_H)' \
+ < $(srcdir)/unistring/cdefs.in.h \
+ > $@-t
+ mv $@-t $@
+BUILT_SOURCES += unistring/cdefs.h
+MOSTLYCLEANFILES += unistring/cdefs.h-t
+CLEANFILES += unistring/cdefs.h
# unistring/woe32dll.h is not public, but is included by other header files.
nobase_nodist_include_HEADERS += unistring/woe32dll.h