summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2020-05-07 20:06:18 +0200
committerDaiki Ueno <ueno@gnu.org>2020-05-07 20:06:18 +0200
commit216010baaeb5577b199c4ae122121673254a189f (patch)
treec7adf7a72f713ecb931725783a5622c06fb3b1d9 /lib/Makefile.am
parent10b6e6a6e705935e39f71d9a5cf06b39f4f3570f (diff)
downloadlibunistring-216010baaeb5577b199c4ae122121673254a189f.tar.gz
build: Update after gnulib changed
In the latest Gnulib, the definition of _GL_UNUSED_PARAMETER is expanded at configure time of the consumer project. Let's include only the fallback definition in <unistring/cdefs.h>. Suggested by Dmitry Baryshkov <dbaryshkov@gmail.com> in: <https://lists.gnu.org/archive/html/bug-libunistring/2020-05/msg00001.html>. * lib/Makefile.am (unistring/cdefs.h): Don't generate the file. * lib/unistring/cdefs.h: Include the expanded form instead of ... * lib/unistring/cdefs.in.h: ... this. * gnulib-m4/.gitignore, gnulib-m4/gnulib-cache.m4, lib/.gitignore, tests/.gitignore: Updated.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 3798a0a..6136ced 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -163,18 +163,7 @@ CLEANFILES += unistring/iconveh.h
nobase_nodist_include_HEADERS += unistring/version.h
# unistring/cdefs.h is not public, but is included by other header files.
-nobase_nodist_include_HEADERS += unistring/cdefs.h
-unistring/cdefs.h : unistring/cdefs.in.h $(UNUSED_PARAMETER_H)
- @MKDIR_P@ unistring
- rm -f $@-t $@
- sed -e '/definition of _GL_UNUSED_PARAMETER/r $(UNUSED_PARAMETER_H)' \
- < $(srcdir)/unistring/cdefs.in.h \
- > $@-t
- mv $@-t $@
-BUILT_SOURCES += unistring/cdefs.h
-MOSTLYCLEANFILES += unistring/cdefs.h-t
-CLEANFILES += unistring/cdefs.h
-EXTRA_DIST += unistring/cdefs.in.h
+nobase_include_HEADERS += unistring/cdefs.h
# unistring/woe32dll.h is not public, but is included by other header files.
nobase_nodist_include_HEADERS += unistring/woe32dll.h