summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-04-10 17:25:47 +0200
committerBruno Haible <bruno@clisp.org>2009-04-10 22:28:44 +0200
commit0ddf471de31d50df52d6ec01a9406f73086c6cb0 (patch)
tree0649226f0f47e368ec824af62f332c1561611080 /lib/Makefile.am
parent2247ec07cae76d7ea6f002d9fa8cd917fd03e1cd (diff)
downloadlibunistring-0ddf471de31d50df52d6ec01a9406f73086c6cb0.tar.gz
Provide installable <stdbool.h>, <stdint.h> replacements.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 86ab54e..36c19ca 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -45,6 +45,51 @@ include_HEADERS = \
# Rules generated and collected by gnulib-tool.
include Makefile.gnulib
+# The <stdbool.h> and <stdint.h> replacements that can be installed.
+nodist_include_HEADERS = \
+ unistring-stdbool.h \
+ unistring-stdint.h
+
+unistring-stdbool.h : $(STDBOOL_H)
+ rm -f $@-t $@
+ if test -n '$(STDBOOL_H)'; then \
+ cp stdbool.h $@-t; \
+ else \
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ echo '#include <stdbool.h>'; \
+ } > $@-t; \
+ fi
+ mv $@-t $@
+BUILT_SOURCES += unistring-stdbool.h
+MOSTLYCLEANFILES += unistring-stdbool.h-t
+CLEANFILES += unistring-stdbool.h
+
+unistring-stdint.h : $(STDINT_H) stdint.mini.h
+ rm -f $@-t $@
+ if test -n '$(STDINT_H)'; then \
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ sed -e 's/@''HAVE_STDINT_H''@/$(HAVE_STDINT_H)/g' \
+ -e 's|@''INCLUDE_NEXT''@|$(INCLUDE_NEXT)|g' \
+ -e 's|@''PRAGMA_SYSTEM_HEADER''@|@PRAGMA_SYSTEM_HEADER@|g' \
+ -e 's|@''NEXT_STDINT_H''@|$(NEXT_STDINT_H)|g' \
+ -e 's/@''HAVE_SYS_TYPES_H''@/$(HAVE_SYS_TYPES_H)/g' \
+ -e 's/@''HAVE_INTTYPES_H''@/$(HAVE_INTTYPES_H)/g' \
+ -e 's/@''HAVE_SYS_INTTYPES_H''@/$(HAVE_SYS_INTTYPES_H)/g' \
+ -e 's/@''HAVE_SYS_BITYPES_H''@/$(HAVE_SYS_BITYPES_H)/g' \
+ -e 's/include_next/include/' \
+ < $(srcdir)/stdint.mini.h; \
+ } > $@-t; \
+ else \
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ echo '#include <stdint.h>'; \
+ } > $@-t; \
+ fi
+ mv $@-t $@
+BUILT_SOURCES += unistring-stdint.h
+MOSTLYCLEANFILES += unistring-stdint.h-t
+CLEANFILES += unistring-stdint.h
+EXTRA_DIST += stdint.mini.h
+
# Libtool's library version information for libunistring.
# See the libtool documentation, section "Library interface versions".
LTV_CURRENT=0