summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-04-11 16:09:45 +0200
committerBruno Haible <bruno@clisp.org>2009-04-11 16:09:45 +0200
commitd598f9e1e016735397e9dca53b436d13c6fb28f3 (patch)
tree98b8e47c701495b3f12ea0739c9705cb17ebd134 /configure.ac
parent3f5fe3223382a51a3057e0806aa02463addd12e4 (diff)
downloadlibunistring-d598f9e1e016735397e9dca53b436d13c6fb28f3.tar.gz
Limit the exported symbols through a config.h trick.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 740516f..08541a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,9 @@ dnl Checks for types, header files, functions and declarations.
gl_INIT
+dnl Check for prerequisites of exported.sh.
+gt_GLOBAL_SYMBOL_PIPE
+
dnl Check for tools needed for formatting the documentation.
ac_aux_dir_abs=`cd $ac_aux_dir && pwd`
AC_PATH_PROG([TEXI2DVI], [texi2dvi], [$ac_aux_dir_abs/missing texi2dvi])
@@ -66,5 +69,6 @@ AC_CONFIG_FILES([doc/Makefile],
[FIX_MAKEFILE_DISTRIB])
AC_CONFIG_FILES([gnulib-local/Makefile])
AC_CONFIG_FILES([lib/Makefile])
+AC_CONFIG_FILES([lib/exported.sh])
AC_CONFIG_FILES([tests/Makefile])
AC_OUTPUT